Mobileread
The Vox is losing support
#11  Difflugia 05-12-2019, 02:09 PM
Quote Rob557
May 12, 2019 - My VOX (obtained at a yard sale) has gone through a factory reset, and I'm trying to figure out how to make it functional. In the 2nd step in the setup process, it connects okay to my wifi then briefly checks (apparently unsuccessfully) to find software updates. In the 3rd step, I set the date and time. But in the 4th and final step when it tries to either locate (or create) my Kobo account, the VOX setup process stops with a "connection error" message, apparently because of a "web page not available" message for a website link that no longer exists (https://partner.kobobooks.com/ ...).

Any thoughts how to get around the setup process and just use the basic functionality of the VOX as an e-reader/tablet?
I don't remember where I stashed my Vox at the moment, but I'll see if I can find it. I'm pretty sure I had it so that it didn't need to connect for an account after a reset. The hard part is that you need to have root access to it one way or another, either by opening the back to get at the internal SD Card or by spoofing the initial firmware check with the Apache web server and sideloading a rooted firmware image. You'll essentially need to do either this or this.

I'm pretty sure the account setup can be skipped by deleting an app from the device, but deleting the wrong one will cause the Vox to do a factory reset again after something like five boots. If I can find my Vox and the battery will still take a charge, I'll see if I can narrow down what needs to be done.
Reply 

#12  mightyzazz 07-15-2019, 07:05 AM
Hi Difflugia, Old Friend.
You helped me years ago root my kids two Kobo Voxs, and they have worked to this day. Like others on this forum, I had to reset one of them last week, and Yes, I now have the same problem. This week I successfully created a new rooted sdcard using your original instructions (they still work! including the firmware download, but the signed superuser zip has to be sourced elsewhere now), but it also gets stuck in the forced reset stage. I have the original unrooted sd card which still works fine. I also tried to create an image of my still working rooted sd card from my other Vox, to put on an sdcard into my bricked device, but it failed. If either of these sd card images could be of use to you, let me know.

By the way, if you take apart your Vox to get to the internal sd card, and you break off the small square of plastic internally covering the sd card and re assemble it, you never more have to unscrew it to have internal sd card access.

Please let me know if you have any hacks I could try to get around this problem.

Thanks Again.

Roberto.
Reply 

#13  oldyellr 08-27-2020, 01:04 PM
Well my Vox finally bit the dust. Seems the battery had died and when I started it plugged it, it was like it was brand new. I went through the steps, but it choked on the last steo, signing into my account with "We page not available" and a connection error message. It looks like Rakuten does not support loging in from the Vox.
Reply 

#14  PeterT 08-27-2020, 10:36 PM
Isn't that what the initial post of this thread says?
Reply 

#15  oldyellr 08-28-2020, 10:20 AM
As I said in post #3, this same thing happened ocer a year ago, but I managed torecover and start from scratch, having to search for old versions of apps compatible with the old Vox Android version. This time it wouldn't connect. I got a good almost 10 years out of it. Meanwhile I'm finishing my current book on a crappy $35 Android tablet.
Reply 

#16  alopan 09-21-2020, 02:59 PM
Hi guys, this is my first post here :-) I had the same problem with Kobo Vox. I patched Kobo Setup Wizard (KoboSetupWizard.apk) and skipped Kobo account registration. It's not an ideal solution because you can't use the Kobo app for reading, but it's better than nothing.

If you are interested, you need to download a zip file with a patched apk and replace original apk on SD card with the patched version.

Step by step:
0. make SD card backup
1. download attachment and unzip it (apk md5 sum: 7ec501f49d0ce73da96379da7bbcde89)
2. put SD card in a computer, mount SD card
3. delete files KoboSetupWizard.apk and KoboSetupWizard.odex in folder /system/app
4. copy patched KoboSetupWizard.apk to /system/app (patched apk contains code, so you will copy only 1 file)
5. unmount the SD card, put the SD card in the tablet.
That's it.

Helpful links:
- Kobo Vox disassembly
https://liliputing.com/2011/11/kobo-vox-tablet-teardown-reveals-an-internal-sd-card-slot.html
https://www.flickr.com/photos/syamastro/6346950395/
- How to mount/unmount SD card and copy files to /system/app (many thanks Difflugia)
https://www.mobileread.com/forums/sh...&postcount=161
- Essential Kobo Vox Apps and Tools (some of them I collected by using Internet Archive https://archive.org/; you can download it here)
https://goodereader.com/blog/electronic-readers/essential-kobo-vox-apps-and-tools

Last remarks:
- when you insert the SD card and power on your Kobo Vox, you will
see something like "Congratulation! blah-blah-blah.... blah-blah-blah" on the last wizard's page. Don't press the blue button Continue, press the Home button on the tablet instead
- you can add Facebook and Google accounts (the patched wizard will skip this step) in the menu Settings
- don't use the Kobo app (I hope you understand why ;-)); use other apps for reading. Probably the best decision is just to delete this from the tablet (read the forum). And please, make a copy of your SD card before you do something
- sorry, but I don't know how to do it on Windows (maybe you can use WSL (Windows Subsystem for Linux) but I'm not sure). It's will be your homework ;-)
- I'm not a native speaker (as you see while reading this text :-)) I welcome the community to help people who will ask about technical details (''How to....?"). Also, read this forum as a source of information; a lot of information about Kobo Vox you can found here. For example, this topic is gold.

Good luck!
Reply 

#17  alopan 09-21-2020, 03:52 PM
Maybe something wrong with the forum engine... Look at the attachment mentioned in the previous post here.
[zip] KoboSetupWizard.zip (2.79 MB, 72 views)
Reply 

 « First  « Prev   (2/2)
Today's Posts | Search this Thread | Login | Register