Mobileread
Troubleshooting Kindle Dx Graphite with corrupted software, does not switch to "registered"
#1  wincel 02-04-2017, 05:08 PM
I'm really desperate by now and would very much appreciate if someone can help solve that.
My Kindle DX is at latest updates, standard software from Amazon, used daily and not problem with network or whatever. It started acting up two days ago when it would not manage to connect to the Kindle store despite displaying bars and 3G symbol.

I tried a soft and a hard restart without any change. Then I reset it to factory results. After trying to re-register it, the circle would just keep rotating without any effect and then it would tell me that it could not connect and I should try again soon. At this point I could not only see the bars (4 out of 5) and 3G symbol but I could browse the Kindle shop just fine ...
The Kindle still showed as registered in the Amazon account too. I de-registered it online via website. Tried to re-register it again via Kindle. Same thing, claiming it could not reach the network - but network was fine, browsing the store no problem, 3G and 4 bars.

I contacted Amazon tech support and they tried the same things: restart, register via Kindle (failed again), reset to factory, register via Kindle (failed). Then Amazon manually registered it online for me, but my Kindle still shows as unregistered on the device. I can browse the shop, I can download samples, I can even buy books and then it suddenly says "(my name) we are sending you your book ..." and it pops up. I can send books from the website from my collection and it shows up. But any feature that is based on Kindle switching to "registered" mode is greyed out, because the software on my Kindle somehow does not make the switch fully. I can't sync, I can't reach my archive, I can't use collections.

I asked the Amazon tech support if they can reinstall my software. They say they can't update the software, I am already at 2.5.8. I told them I'm not looking to update, I just want it reinstalled, I can go to recovery mode in my Kindle (took lots of googling to find that information), I just need a 2.5.8 that is not corrupted. They said they don't have access to that version.

I have another Kindle DX here with broken screen but it seems to switch on and was wondering if I can extract that 2.5.8 and reinstall it on my otherwise functional other DX? I read that there is some personal information in those images that can Amazon make ban your DX? If that is true: how would I get the 2.5.8 from my kindle DX with the broken screen extracted (needs to be done via PC as the screen is just bars/lines), replace the personal information/identifier from that one with my 2nd one with the software corruption and install it on the 2nd DX?

Maybe of interest to anyone else, I got some information about tech support modes for the DX:
A) Reaching the recovery with 2.5.8:
1. Hold Power button for 30 seconds
2. Release Power button and immediately start pressing Home button until screen starts blinking (ca. 40 seconds)
3. Release Home button
4. Enter "RESET" via keyboard, wait for the loading bar to finish = it goes into reboot mode
5. Theory now: connect to PC (it is all empty for my under Windows 10), dump update file into drive and ... then what? Dumping the 2.5.8 update file from Amazon into it does nothing
6. Unplug from PC
7. hit R4 to reboot (?)

B) Reaching tech status page on DX with 2.5.8: Hold ALT button pressed while typing Y-Q-Q to reach "page 611", which shows network status, SIM status etc etc

C) Reinstall (?) with linux while in recovery mode:
Connect kindle to the usb port you will see Usb connected.
In terminal (console) write:
fdisk -l
this will list all drives on the computers
Look for a 3.65 GB (can try df -kh as well) drive and make sure it is the Kindle. Remember it's device id. It should be something like /dev/sdc or /dev/sdd it will be last in the list.
then Type:
dd if=/path/to/rootfs.img of=/dev/sdd1 bs=1024
Wait till this command finishes and Press (R 4)
Kindle will reboot and starts.
Make Factory Reset from settings and thats all.
This should help in you case.

But I have no linux system ...
Reply 

#2  wincel 02-04-2017, 06:19 PM
Is this of any use? There is the 2.5.8 source code on the Amazon website, but I'm not programmer or so which means I have no idea what to do with this ...
https://kindle.s3.amazonaws.com/Kindle_src_2.5.8_555370010.tar.gz
Reply 

#3  wincel 02-04-2017, 06:42 PM
Amazon has provided the source code for all the versions it turns out btw: https://www.amazon.com/gp/help/customer/display.html?tag=mr060-20&nodeId=200203720
Reply 

#4  wincel 02-04-2017, 07:03 PM
Found this: https://www.mobileread.com/forums/sh...ad.php?t=91862 which is absolute Chinese for me. Could someone compile this maybe and provide it since the source code is free now?
Reply 

#5  NullNix 02-04-2017, 07:05 PM
Quote wincel
Amazon has provided the source code for all the versions it turns out btw: https://www.amazon.com/gp/help/customer/display.html?tag=mr060-20&nodeId=200203720
That is not the source code for everything, only for the GPLed and LGPLed portions (things like the font renderer, the kernel, etc: lots of largely-invisible infrastructural stuff). The actual ebook reader, store frontends and user interface code are non-free proprietary stuff which we only get in compiled form and cannot rebuild.
Reply 

#6  jhowell 02-04-2017, 07:12 PM
The source code provided is just for some of the components of the Kindle firmware. They need to release that to meet the terms of the license to use that software. It is far from complete and of no use to you.

On the Kindle DX Software Updates web page there are links to download Software Update 2.5.8 and the Kindle Services Update. There are different sets of these files for different DX models. Check your serial number to see which apply to your device.

Since you already have 2.5.8 installed I doubt that the kindle will allow it to be re-installed.

You haven't mentioned the Kindle Services Update. Have you ever installed it?

It was required to be installed to prevent the sort of connectivity problem that you are experiencing. Though you should have had a problem long before now without it. I suggest that you try downloading and installing that update.

Again, you have to use the one for your exact model. There are multiple links on the page that say "Kindle Services Update" and they link to different files.
Reply 

#7  knc1 02-04-2017, 08:41 PM
Quote wincel
Found this: https://www.mobileread.com/forums/sh...ad.php?t=91862 which is absolute Chinese for me. Could someone compile this maybe and provide it since the source code is free now?
The author of the post that link points to also has been a Lab126 employee.**
(In system security, not system development, but still, that work most likely benefits from on-the-job knowledge.)

** Not a great secret, he includes it on his resume.
Reply 

#8  wincel 02-05-2017, 02:25 PM


Yes I've installed the March update. As I mentioned, it connected online just fine, but the Kindle itself does not switch the MODE after it has registered. It is stuck in the software thinking it needs to be registered - but registration never finishes or updates to "registered" locally even though it IS registered (I can see it online via website, I can send it books via website, I can buy books via Kindle). Which blocks me from using any of the software features a Kindle has once mode is switched to "registered".
NullNix do you think that could be what the open source pack contains? You think it makes sense trying to flash it?

I've bought a replacement Kindle DX screen and found some DIY websites for how to swap it. So I'm going to try that to fix the one with the broken screen. Can I then extract the 2.5.8. from the one with the broken screen to flash it onto the one which has the software issue? How would one do this? My husband spent a few hours yesterday to install Linux and get it set up as the "compile sourcecode and modify and flash Kindle" link laid out.

I've read somewhere that someone got blocked for providing his Kindle 3 (?) sourcecode because there are identifier in it. If the software from the broken-screen DX is extracted and flashed on the software-issue DX, would that be a problem then? How could one avoid that?

And no, I've no computer or programming background, really scrambling here as layman trying to find a solution ... I'm a scientist in biology who needs a large screen for PDF and diagrams, Amazon just tries to sell me the small 6" ones.
Reply 

#9  jhowell 02-05-2017, 03:11 PM
The same sort of problem, the device being unable to interact with Amazon services, has been reported by owners of other older Kindle models in another thread. Perhaps the problem is at Amazon's end.
Reply 

#10  eshafer15 02-06-2017, 10:18 AM
I'm having the same exact issues with my DX and I tried everything above and still couldn't connect to register. I can browse the kindle store and use the browser. What is interesting is if I request a sample of a book using my browser on my notebook. If I try to register on my kindle it will timeout yet it WILL download the sample chapter. So.....one way around this is every time I want new book(s) I just buy them online, send them to my Kindle DX, try to register, wait for it to timeout and then the book(s) appear. Same process if I want to restore an archived book. I tried the factory reset, etc. and Amazon support said they do not see where a factory reset was requested. I also had to get Amazon to manually register the device for the above registration hack to work. This all started after I did a factory reset since I was going to give my brother my DX and just use my Paperwhite.
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register