Mobileread
Cool Reader Font Warning after update
#1  VelvetElvis 02-24-2019, 01:34 PM
No issues with Cool Reader for a few years, until I updated it last night. Now whenever I start the app, return from the Options settings, or switch between day/night, I get the following warning:

“Font "Roboto" isn’t compatible with language “en-US”. Instead will be used fallback font.”

Tried ALL the Cool Reader fonts with the same results. No difference between the CSS being enabled or not either.

Has anyone got any ideas as to cause or solution? Using Android 4.2.2 on an Asus tablet.
Reply 

#2  M_Faust 02-24-2019, 02:15 PM
In book's properties language is specified in uppercase (EN instead en). If you don't have crash, don't mind it - it just informarmational. They promise fix it in the next version.
Reply 

#3  VelvetElvis 02-24-2019, 03:02 PM
Quote M_Faust
In book's properties language is specified in uppercase (EN instead en). If you don't have crash, don't mind it - it just informarmational. They promise fix it in the next version.
Wow, that was fast! Thank you for this! Will look forward to the update.

FWIW, this is the first update that didn't respect my CSS setting of OFF. Not a big deal - simply had to enable, then disable Document Internal Styles.
Reply 

#4  henry45 03-02-2019, 03:34 PM
Just update with latest release , Crashes are fixed.

Source : https://play.google.com/store/apps/details?id=org.coolreader
Reply 

#5  VelvetElvis 03-02-2019, 04:39 PM
Thanks for the update. :-)
Reply 

#6  VelvetElvis 03-03-2019, 02:12 PM
Quote henry45
Just update with latest release , Crashes are fixed.

Source : https://play.google.com/store/apps/details?id=org.coolreader
Went to update, and no update found. It seems they didn't change the version number, which is still sitting at 3.2.29-1, which is also the version number containing the bug mentioned at the beginning of this thread.

I don't want to uninstall/reinstall because of the numerous custom settings I've made.

Will have to switch readers for now, and hope this gets sorted out later.
Reply 

#7  emma88 03-27-2019, 08:20 AM
I need to try Cool Reader app on my tablet. they are lot of options on free version.
Reply 

#8  VelvetElvis 03-27-2019, 09:08 AM
“Font "Roboto" isn’t compatible with language “en-US”. Instead will be used fallback font.”
also happened on my GF's Fire tablet. Update not found.

Wound up having to blow the cache and settings uninstall/reinstall. :-(
Reply 

#9  M_Faust 03-27-2019, 09:42 AM
Quote VelvetElvis
I don't want to uninstall/reinstall because of the numerous custom settings I've made.
Almost all custom settings store in folder .cr3 in root.
Reply 

#10  VelvetElvis 03-27-2019, 10:05 AM
Quote M_Faust
Almost all custom settings store in folder .cr3 in root.
Thank you.

It appears, however, that the update that was posted had the same version number as the installed version, so Google Play wouldn't think an update was warranted. Looked around for an .apk, to sideload, but without success.

I'm fairly diligent on frequently checking for updates, so anyone updating an older version of Cool Reader may not have seen this issue.

Problem confirmed twice for me on two devices.
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register