Mobileread
KT2 Using 'imx_usb u-boot.bin' to unstuck at tree
#1  discombulate 11-23-2022, 04:09 PM
My kindle is stuck at 'boy reading under tree' image. If I try to reboot, it again gets stuck at this same image. I tried solving this using the guide present here https://www.mobileread.com/forums/sh...d.php?t=340387.

After shorting TM401 and TP1706 and then rebooting 'dmesg' gives the following output:
Code
[ 215.919820] usb 3-2: new high-speed USB device number 5 using xhci_hcd
[ 216.068426] usb 3-2: New USB device found, idVendor=15a2, idProduct=0063, bcdDevice= 0.01
[ 216.068430] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 216.068431] usb 3-2: Product: SE Blank MEGREZ
[ 216.068432] usb 3-2: Manufacturer: Freescale SemiConductor Inc
[ 216.069717] hid-generic 0003:15A2:0063.0005: hiddev2,hidraw4: USB HID v1.10 Device [Freescale SemiConductor Inc SE Blank MEGREZ] on usb-0000:00:14.0-2/input0
I get the following output when I use imx_usb_loader to boot a uboot binary:
Code
ok@ok:~$ sudo imx_usb ./Fastboot-Kindle/u-boot.bin
config file </usr/share/imx-usb-loader/imx-loader.d//imx_usb.conf>
vid=0x066f pid=0x3780 file_name=mx23_usb_work.conf
vid=0x15a2 pid=0x004f file_name=mx28_usb_work.conf
vid=0x15a2 pid=0x0052 file_name=mx50_usb_work.conf
vid=0x15a2 pid=0x0054 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0063 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0071 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x007d file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0080 file_name=mx6_usb_work.conf
vid=0x1fc9 pid=0x0128 file_name=mx6_usb_work.conf
vid=0x15a2 pid=0x0076 file_name=mx7_usb_work.conf
vid=0x1fc9 pid=0x0126 file_name=mx7ulp_usb_work.conf
vid=0x15a2 pid=0x0041 file_name=mx51_usb_work.conf
vid=0x15a2 pid=0x004e file_name=mx53_usb_work.conf
vid=0x15a2 pid=0x006a file_name=vybrid_usb_work.conf
vid=0x066f pid=0x37ff file_name=linux_gadget.conf
vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
vid=0x0525 pid=0xb4a4 file_name=mx6_usb_sdp_spl.conf
config file </usr/share/imx-usb-loader/imx-loader.d//mx6_usb_work.conf>
parse /usr/share/imx-usb-loader/imx-loader.d//mx6_usb_work.conf
Trying to open device vid=0x15a2 pid=0x0063
Interface 0 claimed
HAB security state: development mode (0x56787856)
== work item
filename ./Fastboot-Kindle/u-boot.bin
load_size 0 bytes
load_addr 0x00000000
dcd 1
clear_dcd 0
plug 1
jump_mode 2
jump_addr 0x00000000
== end work item
No dcd table, barker=402000d1
loading binary file(./Fastboot-Kindle/u-boot.bin) to 00980000, skip=0, fsize=16334 type=aa
<<<90932, 91136 bytes>>>
succeeded (status 0x88888888)
jumping to 0x00980400
HAB security state: development mode (0x00000000)
config file </usr/share/imx-usb-loader/imx-loader.d//mx6_usb_work.conf>
parse /usr/share/imx-usb-loader/imx-loader.d//mx6_usb_work.conf
Trying to open device vid=0x15a2 pid=0x0063.........................
Could not open device vid=0x15a2 pid=0x0063
Now, I should see Amazon Kindle connected in 'lsusb' or 'dmesg' but the output of 'dmesg' instead shows:
Code
[ 254.974836] usb 3-2: USB disconnect, device number 5
Similarly, 'lsusb' also does not list the kindle. I've tried using the u-boot.bin provided in the guide as well as extracting from factory firmware version using kindle-tool. I did once manage to get it to be recognized as amazon kindle but then couldn't follow further steps of guide as I was using fastboot for android. After compiling the fastboot for kindle, I tried again but I am getting the same output as shown above.

I would greatly appreciate your help in fixing my first kindle that I purchased from 4 months of savings.
Reply 

#2  eddie.t.h 11-24-2022, 01:42 PM
With this method you will not fix your kindle. Since it stops at the picture of the boy under the tree then the uboot as well as the kernel are working. You probably just need to reload the software. Your best bet would be to connect to the reader's serial port and see what's really going on.
Reply 

Today's Posts | Search this Thread | Login | Register