Mobileread
Content server rejects correct username and password
#1  g_man 08-21-2020, 09:45 PM
I access content server on my Kobo e-reader and on my android phone using chrome. I just set up a username and password. When I access the server on my phone it rejects the correct username and password (keeps asking for it after I press sign) in.

The test server function in calibre also rejects them(it clears the entries and asks again). It did work on the phone then stopped working after I had edited a books metadata on the phone.

Odd thing is, when I pass them in the url on the Kobo browser i.e http//usernameassword@IPadress:8080/mobile they work, I tried that in chrome and it didn't work.


I've attached the server logs.

Any ideas.
[txt] server-access-log.txt (613.6 KB, 59 views)
[txt] server-log.txt (6.2 KB, 55 views)
Reply 

#2  kovidgoyal 08-21-2020, 11:40 PM
How are you running the server, and choose simple values for username and apssword without any special characters.
Reply 

#3  g_man 09-06-2020, 05:08 PM
Just using letters and numbers. It's only when I'm trying to access server from mobile phone. Both the phone and the server are on the same wifi network There is no problem with Kobo reader connecting to server. The phone can access the server if no username and password needed.
Reply 

#4  kovidgoyal 09-07-2020, 12:17 AM
The server doesnt care how its accessed, it serves the same data to all clients. Note that chrome on mobile phones sometimes requires the password to be entered multiple times.
Reply 

#5  g_man 09-11-2020, 06:50 PM
I enter the username and password numerous times still keeps asking for username and password.

I tried using another browser and had same behavior. It accessed the server the first time. I edited metadata (added a tag) then subsequently it started rejecting the credentials. This is what happened with chrome. It's after that first use that it stops accepting the credentials. I can't figure out what is happening during the first use to make this happen.

I think it happens when I make a change to a book. Don't have the problem with the kobo browser but I don't edit books using the kobo. It has something to do with making any changes to books. It used to work in the past.
Reply 

Today's Posts | Search this Thread | Login | Register