Mobileread
Option to add 'Greek' is missing?
#1  jerry7171 02-26-2020, 09:08 AM
Today I added a paper written in Greek to my Calibre library. In the GUI, down in the Languages box, I tried to add 'Greek' as the default language of the paper. Instead I get an error message stating "The language Greek is not recognized."

I went to look for the the language in ISO 639 at the Library of Congress site to make sure I was using the correct syntax, but Greek is listed as "Greek, Modern (1453-)."

Previously this was the option listed but I can't find it now? Is this a bug? The only thing that shows up now is "Greek Sign Language."

I'm using Calibre, version 4.11.2

Please see the attached screenshots.
Screen Shot 2020-02-26 at 07.41.39 (2).png Screen Shot 2020-02-26 at 07.41.48 (2).png 
Reply 

#2  kovidgoyal 02-26-2020, 11:40 AM
Its modern greek type modern and you should see it in the drop down list
Reply 

#3  kovidgoyal 02-26-2020, 11:48 AM
And this should take care of using the inverted name form in the GUI fo rthe next release: https://github.com/kovidgoyal/calibre/commit/9864af035af39f054611beba99a900f203a0886d
Reply 

Today's Posts | Search this Thread | Login | Register