Mobileread
Bug - wrong UI language until settings opened
#1  Roguish 02-16-2020, 01:05 AM
How to reproduce? Install Sigil on a Win10 machine in a region where the local language is not English, e.g. Thai in my case. (Windows own UI language is English, but that doesn't matter.) Start up Sigil. Note that the UI language is the region's local language (Thai in my case). This behavior itself is not a bug.

But guess what? Open up the Preferences dialog, go into the Language tab, and notice that the language is already set to English for both UI and metadata. That's strange, because the UI is not being displayed in English.

Now, without changing anything in the Language settings (so leaving them set to English), exit the Prefs and then the entire application. Start it up again. Now it's in English! Apparently the Language settings got "initialized" by going into the relevant Preferences tab.

A minor bug, I know... it's just a little inconvenience that after a new install I have to start it up, "init" the Language settings by going into the screen, closing and restarting. Just thought I'd report it.
Reply 

#2  BeckyEbook 02-16-2020, 04:06 AM
I noticed this problem before and it should be fixed in version 1.1.0. Works well for the Polish language.

Delete the sigil.ini file and check again.
Starts Sigil, the language should switch to Thai.
And now in the Preferences you do not have UI Language as Thai?

Thai system language (th_TH) should correctly save in the configuration as:
Code
ui_language=th
In my case, the Polish locale language in Windows (pl_PL) is saved as:
Code
ui_language=pl
Reply 

#3  DiapDealer 02-16-2020, 08:16 AM
This definitely should have been addressed in Sigil v1.1.0.
Reply 

Today's Posts | Search this Thread | Login | Register