Mobileread
Any way to disable hardware rendering in the new reader?
#1  ownedbycats 02-08-2020, 01:21 AM
The new Calibre reader apparently uses some kind of hardware rendering/acceleration, which results in FRAPS hooking into it and a giant FPS counter in the top right corner. A bit distracting, that.

Rather not turn off FRAPS or the counter overlay entirely as I like to read while waiting for games to load. No way to disable it per-application.

Is there some option I missed to disable hardware rendering in the reader? Thanks in advance.
Reply 

#2  kovidgoyal 02-08-2020, 01:23 AM
https://doc.qt.io/qt-5/qtwebengine-debugging.html

use --disable-gpu via the environment variable as described there.
Reply 

#3  ownedbycats 02-08-2020, 01:45 AM
Thank you
Reply 

#4  DNSB 02-08-2020, 08:52 PM
Quote ownedbycats
The new Calibre reader apparently uses some kind of hardware rendering/acceleration, which results in FRAPS hooking into it and a giant FPS counter in the top right corner. A bit distracting, that.
Given that the latest version of FRAPS is ~6 years old, might it be time to give it a decent burial? I seem to remember my son deep-sixing it when he moved to Windows 8.1 in early 2014 though I'm not sure if that was due to incompatibilities with his new computer or just not wanting it anymore.
Reply 

#5  ownedbycats 02-10-2020, 08:29 PM
Quote DNSB
Given that the latest version of FRAPS is ~6 years old, might it be time to give it a decent burial? I seem to remember my son deep-sixing it when he moved to Windows 8.1 in early 2014 though I'm not sure if that was due to incompatibilities with his new computer or just not wanting it anymore.
I've been looking at alternatives, honestly, especially since FRAPS doesn't work too great with some newer games that use different rendering modes (e.g. Vulkan).
Reply 

#6  Kuram 02-26-2020, 11:15 PM
How or where exactly do you apply this environment variable? I find myself needing to disable acceleration as well, though for me it's because g-sync causes havoc and makes my screen flicker when I'm trying to read due to the low refresh rate. Not a pleasant experience.

As for the question about fraps, if you use it for video recording, consider shadowplay through geforce experience if you have an nvidia gpu. If you use it for a framerate counter, rivatuner works great.
Reply 

#7  Kuram 03-09-2020, 01:22 PM
Bumping this up. I've tried editing the path environment but that didn't do anything for me. I'm at a loss as to where I actually apply this environment variable.
Reply 

#8  kovidgoyal 03-09-2020, 01:27 PM
A quick google will tell you how to set environment variables in windows. Or read the bottom of https://manual.calibre-ebook.com/customize.html#environment-variables
Reply 

#9  Kuram 03-09-2020, 04:44 PM
Right, I've read those, but maybe I'm missing a step or piece of info in between everything because I am not sure what to put. Assuming I need a specific name that I dont know that calibre checks? And then --disable-gpu is the value? I don't want to disable all hardware acceleration, only that for calibre's reader.
Reply 

#10  sjfan 03-09-2020, 05:16 PM
Quote Kuram
Right, I've read those, but maybe I'm missing a step or piece of info in between everything because I am not sure what to put. Assuming I need a specific name that I dont know that calibre checks? And then --disable-gpu is the value? I don't want to disable all hardware acceleration, only that for calibre's reader.
Kovid linked the info above: https://doc.qt.io/qt-5/qtwebengine-debugging.html

The environment variable you want is:

QTWEBENGINE_CHROMIUM_FLAGS="--disable-gpu"
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register