Inkpad 3 issues
#1  MciMc8 07-11-2019, 11:57 PM
Started how with fast battery depletion on my Inkpad 3. Tried different combinations of settings and finally did a factory reset as suggested by Pocketbook support.
Now my inkpad freezes after a few minutes of reading and I just tried playing some mp3-s and it froze after about 5 minutes. The only way to get it restarted is to plug it into a power source.
I am getting constant file system error notification but doesn't seem to be an error and no problems when running through repair procedure.
When the inkpad restarts it takes me back to the beginning setup process.
I am wondering if firmware and software are the same on the inkpad??
Can I reinstall the firmware? How do I get to the root files on the Inkpad?

It doesn't appear that anyone has had as many issues at the same time as I am having. Nor have I seen any solutions -- seems to be a dearth of answers.
Pocketbook support doesn't seem to have answers which is surprising or is there a way to get their attention. Can't find if they give a one year warranty so I can send it in for repair or replacement?

I haven't mentioned a number of little glitches that appear with the major ones. Reverts to default font and size after freezing. Doesn't remember the page I am on when it freezes so it reverts to the last 'known' font.
It will stop charging before it reaches 100%. Even though I have shutdown after x minutes turned off it will still turn off randomly.
Help greatly appreciated. I have emailed Pocketbook support again.

#2  LucyOne 07-12-2019, 02:07 AM
Have you also tried formatting the internal memory?

#3  MciMc8 07-12-2019, 12:50 PM
No -- haven't tried that one yet -- I would like to reinstall the firmware -- have you done this and with what result?

#4  MciMc8 07-12-2019, 01:05 PM
I reformatted the internal memory. Thought there was some ilmprovement (display of library) but when I disconnect power I can only read for a few minutes before it freezes and won't restart unless I reconnect power.

#5  LucyOne 07-12-2019, 04:07 PM
I think Forkosigan is a member here, too. He's from the Pocketbook support team. Write to him to ask about a repair under warranty.

#6  rkomar 07-12-2019, 04:11 PM
I'm not sure if this is as big a problem as it used to be long ago, but badly formed ebooks could cause similar problems to what you are seeing. There is an automatic process that searches the filesystems for ebooks, and then analyzes them and adds the details to the library database. It was possible for a badly formed ebook to cause the analyzing program to run at 100% for a long time, running out the battery and keeping the rest of the ebooks from being analyzed. The only solution was to remove the bad ebook from the device. So, you could try removing all your ebooks, and then adding them back gradually until you see the device acting up again. You might be able to find any bad ebooks that way if that is what is causing your problems.

#7  MciMc8 07-12-2019, 07:34 PM
Right now I have only a few of my own ebooks left on my inkpad. Is there any way to tell if the program is stuck at 100%? And, do you know how to re-install the firmware so I can start completely fresh. I can clear my ebooks from the device and see if that makes a difference -- thanks for the idea, will update.

#8  MciMc8 07-12-2019, 07:50 PM

#9  rkomar 07-12-2019, 07:52 PM
You need to run a command-line shell on the device. You can do that by installing pbterm and typing at a software keyboard on the device, or by installing a networked shell connection program like utelnetd and typing at an external computer. Once you have the shell running, you can run 'ps ax' to see what is currently running on the device. 'top' will work if you are using the networked connection (not sure that pbterm will work with a dynamically updating program like top).

If you're desperate, you can right a shell script that runs 'ps ax' and writes the output to a file on the SD card. If you give the script the '.app' suffix and put it in the Applications directory, then you can run it from the Applications tab.

#10  MciMc8 07-12-2019, 11:29 PM
At 100% charge inkpad thinks it is out of power and shuts down -- not freezing. I am waiting for someone to tell me how to re-install the firmware and hopefully start fresh. I found a thread on the INkpad 2 for installing firmware -- holding power button or both page buttons -- something like that but is it the same for the inkpad 3? I don't want to brick it.
So, hoping that somebody can tell me whether it is possible to reinstall the firmware and if so, how to do it.

  Next »  Last »  (1/5)
Today's Posts | Search this Thread | Login | Register