Hanlin A9 stopped working, firmware request
#1  tpeterka1 12-14-2021, 10:03 AM

I've had my Hanlin A9 Ebook for just under 10 years now, and it suddenly stopped working.
When I try to turn it on, I hear 4 beeps and the red light on top flashes, then nothing. When I plug in the charger, the lights start flashing in the order green-yellow-red until I disconnect the charger. It stops afterwards. A few times, when I tried turning it on, the loading screen appeared, but it was stuck at 0.

I thought that there would be a good chance of it working again if I updated the firmware, so I looked for it, with no luck unfortunately, since the Jinke website has been gone for quite a long time now. I've tried searching I think almost everywhere (4Shared, Google, Wayback Machine and bunch of others), but I haven't unfortunately found anything.

I found out about this forum when I searched for the firmware, so I decided it would be a good idea to create a new thread here, even though the threads about the A9 here are also like 9-10 years old.
It would be a miracle if someone had the old firmware for this ebook or helped me troubleshoot this problem, as I would really like to keep using it.
If you have the firmware, I would be very grateful if you uploaded it somewhere.


Today's Posts | Search this Thread | Login | Register