Netronix 13.3 receives Android 4.4 Firmware Update
#1  fgdas 03-18-2018, 08:17 AM
Folks from GoodEreader finally released Android 4.4 firmware update which brings:

- better support for newer apps
- faster drawing and writing notes
- more responsive overhauled UI
- over 100 bugs fixes

Anybody could confirm?

#2  Question Mark 03-18-2018, 11:12 AM
They did, indeed, release an update. However, whether that update resolves more issues than it creates is still to be determined. It should be noted that the update will also remove access to the Google Play Store from the device.

From comments on their Indiegogo page where only bonafide backers can post comments, only one person has reported so far on attempting to install the update. It apparently did not go well.

rafepurnell 41 minutes ago

OK…… decided it was worth dusting this POC off to see if the update makes a difference.

Now my drinks tray is stuck in a loop. Telling me Encryption unsuccessful. To resume using your tablet, you need to perform a factory reset.


Can anyone how to remember how to reset this thing?

And also from that same comments page, it seems that quite a number of backers have still not received their devices despite Good Ereader apparently having stock on hand for sale from their own webstore. Some of the Indiegogo backers have been waiting for two years to either receive a device or a refund.

Sen-Wen Chang 11 hours ago

Order ID
Order Date
August 16, 2016

Nothing received

Patrick Fontaine 17 hours ago

selling mine anyone interested , email me at

schoophy 18 hours ago

Hi Michael and Peter,

If you are selling the eReaders at your online stores, that means you have them in stock. Is there a reason that you don’t send the eReaders to your loyal backers first but selling them online to other customers? Many of the backers have been waiting for more than 2 years for the eReaders. Please respond.

Florent Herbinger 23 hours ago

Thanks for the update guys! I am going to test it out now. For other owners, remember to put the “update” zip file in the highest level of the root folder level (i.e. don’t put it in any sub-folders).

Satawat Thongsawat 1 day ago

The second day,
Order ID, 92
Order date, March 28, 2016
Still waiting.
Should I ask for refund?

Will ask everyday.

#3  Question Mark 03-18-2018, 11:30 AM
There is also a comment on Good Ereader's blog site from another backer who reports that the update went smoothly and has increased the device's performance speed.

Vance Vance • 16 hours ago

I have an Apple iMac and was able to copy this Android 4.4.2 update file to my Good e-Reader by using Android File Transfer. Everything worked and it didn’t take long. I am delighted with the speed of operation and the very capable default Notebook. Thank you, good guys!

Good E-Reader Mod • 14 hours ago

Thanks! It took a really long time to get this version of Android to work on our hardware and also fix a ton of bugs!

#4  Question Mark 03-18-2018, 07:54 PM
The update comments thread which I linked to in my last post has disappeared from their website. Wonder what's up...

The one post seemed to be positive. The poster seemed to be very content with the performance after the upgrade.

Maybe that was just an initial impression. Perhaps some significant bugs were later discovered and reported on?

Certainly, the backer on the Indiegogo page who attempted to install the update still seems to be experiencing difficulties:

rafepurnell 10 hours ago

OK…… decided it was worth dusting this POC off to see if the update makes a difference.

Now my drinks tray is stuck in a loop. Telling me Encryption unsuccessful. To resume using your tablet, you need to perform a factory reset.


Can anyone how to remember how to reset this thing?
See less

rafepurnell 2 hours ago
Process of elimination. I knew a key combination on boot would take me to the boot loader. Home Key and push the reset. Hold the home key. The boot loader comes up. So Factory Reset started. Lets see if the update works better on a flattened drinks tray.

rafepurnell 28 minutes ago
That reset seemed to bring the Tablet back, but left me with only Settings, Browser and Animation apps. Rebooting with the on the root of the internal storage. It see the file and asks me if I want to update. I approved it.

rafepurnell 28 minutes ago
Seeing as we have no support forum I will put my logs here. The installation starts and then the installation is aborted. This is what is displayed. Finding update package... Opening update package... Verifying update package... Installing update... Upgrade : ALL include recovery for 4.0 This package is for "ntx_6sl" devices! E:Error in /data/media/0/ (Status 7) Installation aborted. Looks like I am stuck for the time being. On a plus note, the browser seems responsive.

EDIT: The page in question has now returned to their website.

#5  Question Mark 03-19-2018, 09:06 AM
Apparently, the update process is not going so smoothly.

featurex • 3 hours ago

Now my tablet is bricked.

- I ubdated the software
- then i went to settings, about this device and it said there is an update available.
- I installed the update. Now i am stuck with Encryption unsuccessful loop.

Can use the device any more

featurex • 5 hours ago

For me this doesnt work at all.

- there is no root folder on the internal storage nor the sdkard
- there is a root folder on the device if i try to copy it there it say no rights
- do i copy the zip file, or do i unzip the files
- when i long press i only have the option power off or reboot, no Upgrade by SD-Card.

I am on a mac. Tried the Android file transfer, but again no root folder. It would be great if you would put a little extra effort in describing the process.

Please help.

featurex featurex • 4 hours ago

Wow, found out what it was you have to rename the file to

Good E-Reader Mod • 10 hours ago

We are working on a new update available in the next few weeks that solves some bugs that have been reported here and Indiegogo.

#6  Question Mark 03-20-2018, 03:36 PM
It seems that the new update is a bit buggy.

Milton Good E-Reader • 23 minutes ago

Once updated to 4.4, cannot be downgraded to 4.0.4.
The new firmware is so buggy. A lot of time there is no response. The new update may be toward note taking, but not reading e-books. The default pdf reader is gone. It was buggy at times, but at least functional most of time. Now the pdf reader is EZpdf? or Moon Reader. Neither app can turn 1 page at a time. I tried to do factory reset after updated to 4.4, but the issues still remain.
Please make downgrade to 4.0.4 possible. It has some bugs, but at least it's working most of time for reading e-books.

#7  Question Mark 03-21-2018, 05:07 PM
Another owner is reporting difficulties with the new update and is apparently unable to go back to the original firmware.

ri Kabati • 7 hours ago

After playing with my Good e-Reader13.3 for a few hours after the update, I'm now totally depresses that I've packed it to rest in my cupboard, with the hope that the promised fixing update will solve all these issues. The major problems for me are:

1. The external SC card is not viewable or accessible, all books on it cannot be accessed our read.

2. When tried to test reading PDFs on the internal storage, the loading of next/previous page is very slow, with a strange shake, even though I'm enabling the Pre-Render option. In the previous version it was immediate with the press.

3. When tried to go back and flash the previous firmware, it failed continuously. I think your customers have at least the right to go back the original version when the new one is full of bugs, haven't they?

Please, please, bring back to us the pleasant experience with our lovely e-Reader, and I'm sure that you will not leave us hopeless and will do your maximum best.

Many thanks and Regards.

Hi. After the updating my Good e-Reader 13.3, I cannot reach my external SD card anymore, nor read the books on it or even see them, although I've done the update by copying the firmware to it. Now I cannot read any of my books 😢😢. My e-Reader is of no use to me now, very sad.

Today's Posts | Search this Thread | Login | Register