Suddenly my iRiver Story (original) won't play music
#1  James_Wilde 04-30-2015, 06:43 AM
I have recently loaded Faure's Requiem onto my iRiver Story in mp3 format, but it won't play. I earlier had a number of music items on there, one of which I have not removed, a recording of Mozart's Clarinet Concerto. I know this worked before, (about two years ago) but now it doesn't either.

When I go into the folder where music should be I see an upward arrow, two dots and the title, Klarinetkonsert. When I press Enter, I am moved back up one directory to the folder with the name Klarinetkonsert. Of course there should be three mp3s in there, and in my Finder window (on the Mac) I can see them. But they are not visible on the iRiver.

Has anyone else had this experience, and if so, how did you fix it? BTW I have also uploaded the Faure to my iPod and it works fine, so there's no problem with the files.


#2  James_Wilde 04-30-2015, 06:53 AM
Just discovered that some other folders are the same. I can't get into the System folder, for example. When I mark it and press enter, I get the same picture, an upward pointing arrow, two dots, and the name System. Press Enter and I move up a level.

Incidentally, I know the two dots is the computer equivalent of one level up.

#3  James_Wilde 04-30-2015, 11:01 AM
Does anybody know whether resetting the machine erases everything I've loaded, or is it just the firmware that gets a reload?

#4  James_Wilde 06-12-2015, 05:37 PM
OK a new post on this topic. If I use the Back key to take me to Books and then go down to My Folder and then select music, I can't play music. The effect is as described in my original post. However, if I press the Menu key and select Music then I can play music.

Another, and more serious problem is that the disk size and usage is not updating properly. If I have the iRiver connected to my Mac and right-click the STORY device and select Get info, it states that my disk size is 1,79 GB and that I have somewhere in the range of 80- 130 KB of free space. I have now inserted a SD card and moved 12 MB of books to the card and deleted them from the main memory. It is now that the displayed free space has risen from around 80 KB to 130 KB. I would like it to show 12 MB.

Anyone any ideas?

#5  frostschutz 06-13-2015, 02:10 PM
The most common reason for a filesystem to not know about free space is that there is actually no free space... a less common reason is, the filesystem is damaged and needs to be fixed. With Linux filesystems there'd also be a root reserve to consider, but I don't think it exists for FAT filesystems.

#6  James_Wilde 06-13-2015, 07:34 PM
Thanks, Frostshutz. I haven't got my iRiver handy as I write, but I remember that it has 2 GB of internal memory, to which I have added an 8 GB SD card. Of the 2 GB internal memory, apparently 1.79 GB is considered user space. Presumably the remaining 0.21 GB is used by the reader itself. If I remember correctly, the file system is FAT 16, which I thought surprising.

I suppose I could remove all books and the few bits of music from the internal memory and reformat the 1.79 GB disk and see what happens. As it is, I have no way of checking the validity of the firmware which was v1.71 or 1.72, and there is nothing newer.

Any comments, anyone?

#7  Enaj 08-20-2016, 09:40 AM
hello.. I have the same problem you mentioned about the music file only available if I get in the music file by the menu button.. However this is not the main problem.. Although Im able to see the file through the menu-music files... I couldnt play it.. I've tried to play the original iriver song (the iriver - john blackford) and its fine, which means speaker is not the problem.. but once I tried to play songs I transfered.. the media player will 'hang/jam' ( what i means by hang/ jam is after i tried to play my own song.. it will have no respone.. and after that if i try to play the original iriver song... it will no longer responing as well) what I need to do is to turn off the devise and then try playing the original it will be okay.. but once playing my own mp3.. the same situation occured again)

*ps: I tried copy mp3 file into the irirver by usb and Sdcard, or syns using wondow media player.. did I left out something or there is something I can do to solve this problem? Hope to hear advise from everyone. Thanks so much.. ☺☺☺

Today's Posts | Search this Thread | Login | Register