A black cross in the middle of the screen!
#1  mauperio 12-16-2010, 02:52 PM
Hi, when i turn on the device, in the middle of the screen appears a black cross, and the ebookwise remains blocked in this way.
Please, someone help me!
Mauperio from Italy

#2  surrealmind 12-20-2010, 12:20 PM
Hi Mauperio,

Can you give us a little more context? Did you just buy an EB1150, and if so, did it display the cross right out of the box? Is it a new unit or a used unit? Have you tried the manual reset button?

The only place I've ever heard about a cross appearing on the screen is on the comments section of an EB1150 review from 2005, when a user accidentally removed a Smartmedia card from the reader while it was turned on. Check out: <>.

It sounds like his solution involved a firmware update, but I don't know anything about how that worked. Your best bet might be to contact ETI directly, as they have excellent customer service (in my experience). Their email address is <>. Hope this hopes, and good luck on this strange problem.

#3  mauperio 12-24-2010, 08:22 AM
In effect the problem was about firmware, i have charged it again and the device is working.
Thank you for your advice!

#4  FizzyWater 12-25-2010, 02:05 AM
Ah, I was wondering if it was in "calibration" mode! Glad you got it working.

#5  surrealmind 12-26-2010, 07:31 PM
That's great news, mauperio, you're welcome. So did you have to contact ETI to get the firmware?

#6  mark844 12-15-2011, 12:24 PM
I'm now getting that on 2 of my devices. I've tried the reset, removed the battery - still same results when powering on.

I tried the 4.2f17 version of the files used for migrating GEB1150 to EB1150 hoping that the device would flash to an older version of the firmware. No success.

Anyone know where I can find the 4.2f25 version of the files or of another method to recover from this error?

#7  lvd4 12-16-2011, 07:21 PM
I only just noticed that version was on mine. I never had to download it. I thought it downloaded on its own when connected to the computer.

Have you tried reinstalling from
I strongly suggest you contact their support:

They are great!

#8  mark844 12-16-2011, 09:47 PM
Your link is for the USB drivers.

I did get my hands on 4.2f25 binary files that I then put on a SM card and flashed the device. It did solve the issue.

Today's Posts | Search this Thread | Login | Register