Mobileread
Problems - reinstall?
#1  dan2the6th 07-02-2020, 03:36 PM
I've been having weird problems with the calibre reader and editor. I still get that fatal "OpenGL context error" from time to time in the editor. When the reader does that "preparing book for first opening" (or whatever it says) it seems to take forever. I know people say, "But it's only the first time!", but it isn't. I use the editor to repair typos and such, and every time I do that I have to go through the startup preparation again. Right now it's taking about a minute.

What's worse, sometimes the spinning circle just stops, and I have to kill the reader and re-launch it. This also happens on a regular book open, not just the "first opening" thing.

I've never had problems like this with calibre until the last month or so. I'm wondering if it might help to just uninstall it and reinstall from scratch. Any opinions? I assume if I do that, my library will remain untouched.

I'm using v4.19 on Windows 10 2004, 64-bit.
Reply 

#2  BetterRed 07-02-2020, 06:59 PM
A reinstall won't touch your library and configuration, if you're not willing to risk it, see How do I backup calibre?

But I doubt a reinstall will solve your problems

It could be a video driver issue, check to make sure your drivers are up to date.

There have been a couple of similar problems where deleting the configuration data has solved the problem, but that's a drastic step. If you install calibre portable you'll have a pristine configuration that won't disturb your installed configuration, you can then view and edit the same issues on the same epubs.

Hmmm - reading your post again I am wondering if something is 'interfering' with calibre's cache - try relocating it using the CALIBRE_CACHE_DIRECTORY Environment variable. Put the folder somewhere like C:\CalData\Cache

BR
Reply 

#3  dan2the6th 07-02-2020, 07:34 PM
Every time I come up with an issue like this, I'm told "update your video drivers". Sorry, but that's NOT the issue.

Thanks anyhow for the advice.
Reply 

#4  ownedbycats 07-02-2020, 09:57 PM
There's an enviromental variable to disable hardware rendering in Calibre. Have tried that?
Reply 

#5  DNSB 07-02-2020, 10:06 PM
Quote dan2the6th
Every time I come up with an issue like this, I'm told "update your video drivers". Sorry, but that's NOT the issue.

Thanks anyhow for the advice.
Hmmm.... Open GL context errors. You know that does sound like video driver errors.
A quick search on OpenGL context errors, I came up with this response for that error:
Quote
According to the information provided by the error message, the issue you are struggling with came up because your system lacks the required graphics drivers.
Looking at AutoDesk's site:

Quote
Causes:
Outdated graphics card drivers.
Solution:
To workaround this issue, make sure to update the graphics card drivers. Refer to the graphics card manufacturer's website:

Once everything is up to date, run Autodesk products again.

If the issue persists try the following solution:
Switch graphic libraries used by the Single Sign On Component

The Single Sign On Component by default uses Qt. Qt checks the OpenGL drivers 1.3 or later and loads/uses the native OpenGL driver. If OpenGL driver is lower than 1.3, Qt loads/uses the ANGLE library instead. Try entering the following system variables:

QT_OPENGL=angle
QT_ANGLE_PLATFORM=warp

Note: Other possible entered values for QT_ANGLE_PLATFORM are d3d9 and d3d11. Here is an example on how to set up a system variable on Windows.
Even if your video drivers are updated to the latest available, that does not mean that they have updated components such as OpenGL to match the latest requirements.
Reply 

#6  ownedbycats 07-02-2020, 10:14 PM
There's also this fix for Dropbox, although it might not work (or have unexpected results):

Quote
Start a Windows command prompt as an Administrator (an elevated command prompt)

Run this command:

SETX QT_OPENGL software

Close the command prompt.
Reply 

#7  BetterRed 07-03-2020, 03:09 AM
Quote dan2the6th
Every time I come up with an issue like this, I'm told "update your video drivers". Sorry, but that's NOT the issue.

Thanks anyhow for the advice.
I offered four alternatives - reinstall, video driver, try portable, move the cache.

Which you acknowledge with a hissy fit, because you'd been previously offered one of them. Civility is obviously not your strong point.

BR
Reply 

#8  dan2the6th 07-03-2020, 11:20 AM
OK, I am duly and properly chastised. You've convinced me.

This morning I did update my Intel Graphics driver from the Intel web site. The only reason I have not done this before is that Intel always says something like, "This will update your manufacturer approved driver. We recommend only installing drivers provided by Dell." Which sounds scary, so I always waited for Dell to provide updates.

But I bit the bullet and updated regardless. We will see if my problems are reduced. One good sign--when I opened a book in the reader, the "first read" screen only took about 3 seconds instead of 50 seconds.

Thanks to all for your time, and sorry for my little hissy-fit.
Reply 

Today's Posts | Search this Thread | Login | Register