Mobileread
Polishing multiple books failing
#1  lovingfriendstar 06-26-2020, 02:45 AM
Polishing individual books bear no problem but when polishing multiple books, about half of the jobs randomly fail with an error similar to this. These same books can be polished without any error if the process is repeated.

Code
Polish book 1 of 6 (BookName)
Found existing cover page
Python function terminated unexpectedly [Error 5] Access is denied (Error Code: 1) Traceback (most recent call last): File "site.py", line 114, in main File "site.py", line 88, in run_entry_point File "site-packages\calibre\utils\ipc\worker.py", line 209, in main File "site-packages\calibre\ebooks\oeb\polish\main.py", line 291, in gui_polish File "site-packages\calibre\ebooks\oeb\polish\main.py", line 269, in polish File "site-packages\calibre\ebooks\oeb\polish\main.py", line 258, in polish_one File "site-packages\calibre\ebooks\oeb\polish\hyphenation.py", line 16, in add_soft_hyphens File "site-packages\calibre\utils\hyphenation\hyphenate.py", line 116, in add_soft_hyphens_to_html File "site-packages\calibre\utils\hyphenation\hyphenate.py", line 102, in add_to_tag File "site-packages\backports\functools_lru_cache.py", line 152, in wrapper File "site-packages\calibre\utils\hyphenation\hyphenate.py", line 27, in dictionary_for_locale File "site-packages\calibre\utils\hyphenation\dictionaries.py", line 110, in path_to_dictionary File "site-packages\calibre\utils\hyphenation\dictionaries.py", line 72, in extract_dicts
WindowsError: [Error 5] Access is denied
Using Calibre 4.19 on recently resetted Windows 10 2004 64-bit, running on Ryzen 7 1700, 8GB RAM. Also happened on Calibre 4.18 and previous Windows installation too. Still happening even when Kaspersky antivirus protection is disabled.
Reply 

#2  kovidgoyal 06-26-2020, 04:50 AM
Are you sure you are on calibre 4.19 this was fixed in 4.14. https://github.com/kovidgoyal/calibre/commit/0d033196fc2d7f695a42f4a97931fcfe7459e1cc
Reply 

#3  lovingfriendstar 06-27-2020, 11:35 AM
Thanks for replying, Mr. Kovid Goyal. I'm indeed up to date with Calibre, currently using 4.19 64-bit. https://imgur.com/7OMFzEL

Perhaps I should try a complete reinstall by removing the configuration directory? I have been just copy-pasting the configuration folder whenever I have to reinstall Windows so it might have been messed up somehow in the process.

If I have to remove everything to do a clean install, would you be so kind as to point me how to back up settings like my virtual libraries and custom columns, etc? I like the current library UI I've refined over the multiple years I've been using this awesome software.
Reply 

#4  kovidgoyal 06-27-2020, 11:39 AM
No doing a full re-install wont solve the issue, it has nothing to do with configuration. Try the next release, I have added some ore code that might fix the problem, though since I cannot replicate it...
Reply 

#5  lovingfriendstar 06-27-2020, 01:13 PM
Thank you. I will try the next release then. I hope it will be solved.
Reply 

#6  lovingfriendstar 07-03-2020, 04:23 AM
Just tested the new release, did a quick polish on 8 books and and the problem seems to be fixed. Thanks for your hard work.
Reply 

#7  kovidgoyal 07-03-2020, 05:17 AM
You're welcome
Reply 

Today's Posts | Search this Thread | Login | Register