PRS-505 help would be appreciated
#1  lizzielou 04-22-2022, 11:36 AM
I am not sure if anyone can help me here.

I have just bought another Sony prs-505 (I just love them and also the lrf format that everyone seems to hate). This looked just fine when I got it with a few books loaded which worked properly.

I connected to my laptop and the charging light came on but the reader screen froze instead of showing the 'connected' logo, and the charging icon by the battery didn't show. I also loaded Calibre and it was recognised so I copied some books over but when I disconnected it the reader had frozen and I had to do a reset. Once done the books had transferred correctly. Tried this a few times but each time the same problem.

I am not sure if there is something I can do to fix the transfer process.

#2  rcentros 05-23-2022, 01:41 AM
Quote lizzielou
I am not sure if there is something I can do to fix the transfer process.
It might be a hardware issue, but it also might be corruption in your firmware. I don't know if the firmware in Spain would be the same as in the U.S. but, if so, I could link the update.

BTW, there's a forum on this site dedicated to Sony readers, you might want to re-post there to get more responses. I normally don't see posts on this forum.

#3  JSWolf 05-23-2022, 04:05 AM
How can you love the LRF format when it's not really all that good thanks to Sony being too cheap to actually include a full font family? The italics are simulated and they do indeed look fake. ePub on the 505 is a lot better.

Today's Posts | Search this Thread | Login | Register