Problem with Beebook - having to reset to restart
#1  T.J. 09-10-2019, 11:28 AM
Hello everyone,

I have a Bebook Neo, which I have used a lot. The few issues Ivw had with it in the past, Ive been able to solve.
However, this time, no matter what I have tried, I cant solve this problem.

I had finished reading an e-book and was going to select another, which was on another SD-card. I changed cards,the proper way (removing card via the menu before switching it) When I had switched, the Neo didn't show any content on the card, and when trying another one it suddenly showed the contents of the previous one. I tried swapping cards a few times, and after a few attempts, it was showing the correct information. So far so good.

I thought everything was well, but then the Neo turned off all of a sudden in the middle of my reading. but not quite. You see, after it had stated that it was turning off, the screen wwent blank as it does when turning off. This time though, the little indicator light which is psitioned above "menu" and below the screen, didn't turn off. I cant start it, unless I use the reset button located on the back of the device. Nevertheless, it turns off after its been on a few minutes.

I have the last update of the firmware that I know of the Aug2011, one.
I attempted to run the firmware update again, but either I'm doing it wrong, or the Neo doesn't accept this action, due to it not turning off completely.

I'd be very grateful if someone here could please help me to solve this, since I do find the Neo very good and I have loved it from the start.

Thanks in advance.

I'll make sure of sticking around and help others if I can. Been a member before, ánd enjoyed the community a lot.


#2  T.J. 09-23-2019, 05:25 PM
Hello again,

Just wanted to update my post, in case someone here has been or is experiencing the same issue as me.

I have managed to solve this issue by letting the battery of my Bebook Neo comletely drain. Since it was impossible to totally turn it off, I turned off the automatic turn off after a certain time (not that this did any good, since it turned off after a little while regardless of the setting) and also turned on the wifi. I then let it be untill the bluie indicator light went dark, which means the battery is totally drained.

After waiting a while, I charged it and turned it on, navigated around, browsing my boks a little, in order to see whether it would turn off by itself again. It didn't. I went on turning it off, checking whether it would still stall leaving the indicator light shining. It did not. It was, and is behaving exactly as it should. Problem solved.

I attempted this solution, since remembering that the flatest firmware that was officially released to the e-reader had this bug that never got fixed by the company. The bug is that if the battery indicator falls below the third line (in the battery symbol (at the middle of it)) some problem may occur and the Neo may start acting weirdly.

Hope this may help other booklovers in this forum.

Take care, and happy reading everyone!


Today's Posts | Search this Thread | Login | Register