Mobi2Mobi Mobi2Mobi v0.13 - GUI for Mobiperl tools
#1  Jad 03-05-2008, 11:00 PM
****Kindle AZW File Users Alert****
Amazon Kindle (AZW) files now tie the Clipping Limit and TTF Flags into the DRM of the file. Using Mobi2Mobi (GUI) too remove these flags from DRM'd files will result in an unreadable file. Always ensure you only use Mobi2MobiGUI on copies of the original files.
Check the Kindle forum for more information regarding AZW DRM'd files.

v0.11 Has a fix courtesy of DiapDealer to address the potential truncation of the Mobi2Mobi output into the GUI textbox due to NULL characters in the text. The new v0.11 zip also contains the LoRes version of the GUI.

I have also finally released the current VB code for both the FAT & Slim versions of the GUI.

As always make sure you have backups of your files prior to making any mods, especially if you do in place modifications.

Note v0.11 Supports PRC, MOBI & AZW file extensions natively. Kindle users don't need to rename their AZW files to MOBI to use the GUI as some of the older guides on the web refer to older versions of the GUI.


MS .NET Framework 3.5 SP1
Mobiperl Mobi2Mobi tool Perl/Win32 v0.0.42 or greater
VB Source Code requires MS Visual Basic 2008 Express Edition or greater

Please have a play and feedback any comments you have. Make sure you read the ReadMe.txt for the GUI requirements.

The Mobi2Mobi GUI source code is being released under GPLv3. Note that the code is largely undocumented and is released as is. I'm not the tidiest programmer so excuse what are probably a bunch of big no no's in the code. If you make use of the code or make any improvements, please send me a copy as I'm always interested in learning.

image »

image »
[zip] (77.6 KB, 11613 views)
[zip] (46.9 KB, 3895 views)
[zip] (47.4 KB, 3120 views)
[zip] (78.1 KB, 9486 views)

#2  wmaurer 03-06-2008, 11:45 AM
You beat me to it ;-)

Although I was thinking about using Python so that it runs on Linux as well.

#3  jbenny 03-06-2008, 04:39 PM
As soon as I click on "Open File", it crashes. See attached screen dump. I'm running WinXP SP2 and have the dotNet v1 and v2 stuff installed. Other dotNet programs work ok.
[bmp] Error.bmp (422.8 KB, 3828 views)

#4  jbenny 03-06-2008, 04:40 PM
Quote wmaurer
You beat me to it ;-)

Although I was thinking about using Python so that it runs on Linux as well.
This could be a perfect opportunity to learn Mono

#5  Jad 03-06-2008, 05:21 PM
hi jbenny, thats very strange. I initially started development in VC#2008 but decided most people probably wouldn't have v3/3.5 of .NET. I checked the project and its built under .NET v2.0.50727 SP1. It sounds like one of the core system dlls is awol. You can always install the latest v3.5 of .NET as this includes the previous versions and just adds a bit of extra stuff.

Sorry for not having a more definative answer for you.

#6  Jad 03-06-2008, 05:36 PM
Ok back again. I did a check on a non SP1 v2 .NET install and I can reproduce the error that you got jbenny. I installed the SP1 update.

And after the reboot the program worked fine. Give it a go and let me know if you are still having issues.

#7  Jad 03-06-2008, 05:39 PM
Ok my original reply has to be approved by a moderator apparently. jbenny, I tested on a non SP1 v2 .NET install and got the same error. Installing v2 .NET SP1 corrected this.

Give it a go and let me know how you went.

#8  JSWolf 03-06-2008, 06:51 PM
I've just receive a nice crash. I do have the latest .net 2 with all the updates. And I have the latest Mobi2Mobi v36.

System.IO.IOException: The process cannot access the file 'H:\E-Books\SonyReader\MobileRead\PRC\0-AD\mobidata.m2m' because it is being used by another process.

#9  Jad 03-06-2008, 07:45 PM
Thanks for the feedback Jon. I actually just got that error myself. I'll have to look at a better way of doing the open code. Currently I open a new process to run the Mobi2Mobi exe converting the PRC file to a temp MOBI file, at the same time I pipe the output to a text file 'mobidata.m2m'. I have a thread sleep command after the initial process runs before I then read the first line of the text file to retrieve the Database Name. Its a bit of a cludge and sometimes the initial process doesn't close before the system trys to read the file.

Does it do it to you all the time or just the once so far? I'll see if I can find a better way of doing this other than increasing the thread sleep time.

#10  Jad 03-06-2008, 08:06 PM
Ok back again.. I've squashed the 'Being used by another process' bug so hopefully this won't re-occur, also it speeds up the open file and convert process slighty as well. I'll release a v0.02 with these fixes as well as the ability to set a default path for your eBooks. Be up soon, got go get some free morning tea first.

  Next »  Last »  (1/48)
Today's Posts | Search this Thread | Login | Register