k2pdfopt: optimizes PDFs for viewing on e-readers
#2021  taddymack 03-07-2023, 10:07 AM
You're downloading a source code of the download page, not the program.
The first line of the source page reads:
<html><head><title>'s K2pdfopt Download Page</title>
Fill in the captcha and click on the relevant software (v2.54 mac OSX x86 64-bit ?).

#2022  bamboohouses 03-07-2023, 12:00 PM
Thanks for explaining that. One step closer! However I am clicking on the relevant software and that what is downloading so I'm not quite sure what is going on. Very frustrating.

#2023  taddymack 03-07-2023, 02:09 PM
It seems you have to right click on the rectangle (e.g. Mac OSX...) or control-click (when on Mac) on the rectangle and then select Save as... which saves the page, not the program.
Or try a different browser or wait till Willus responds.

#2024  bamboohouses 03-07-2023, 03:26 PM
Great! Good idea - I think a different browser might be better. I was wondering if perhaps the captcha is timing out before the download has fully completed? I'll try your suggestions - Thanks.

#2025  willus 03-07-2023, 10:16 PM
Maybe the video on the mac help page will help?

#2026  bamboohouses 03-08-2023, 03:04 AM
When I try to download the file I just repeatedly get the message "The network connection was lost"

#2027  bamboohouses 03-08-2023, 05:52 AM
Installed Firefox and managed to download the file and properly and install it. It all seems to be up and running so many thanks to everyone for their help. Much appreciated.

#2028  taddymack 03-08-2023, 10:58 AM
@bamboohouses: You're right, Safari doesn't work with the download page, I use that browser only when there are problems with web pages I visit, now it's vice versa.

#2029  willus 03-09-2023, 12:38 AM
Very interesting. I tried the download on my mac mini with Ventura in Safari and sure enough it fails right at the end. Firefox worked fine. I'll see if I can try and figure out what's going on with Safari.

#2030  xilopaint 04-28-2023, 07:09 AM
Hey @willus, would you consider to create a Homebrew formula for k2pdfopt? I use k2pdfopt as a dependency in my Alfred workflow but I can't distribute it in Alfred Gallery as the binary is not notarized and signed with a trusted certificate. An alternative would be installing k2pdfopt via Homebrew. This CLI is maintained for a long time and I think it's popular enough to Homebrew Core.

 « First  « Prev   (203/203)
Today's Posts | Search this Thread | Login | Register