Mobileread
Anyone else unable to log in to the Google Play store?
#1  4691mls 06-14-2022, 05:57 PM
SEE SOLUTION IN POST #4 BELOW

Several days ago I bought a book from Google Play using the Android app on my phone. I then tried to sign in to the Play store on my Windows 10 PC so that I could download the book and transfer it to my ereaders. However, when I signed into Google and tried to access the Play store I got an error message.

I figured the Play website was just having a problem that day so I let it go for a few days and tried again today but I'm still having the same problem. I can access the store if i am NOT signed into my google account, but if I either
1) sign into Google and then try to access the store or
2) while not signed in, access the store (this does work) and then try to sign in I get the following error:

"500. That’s an error.
There was an error. Please try again later. That’s all we know."

I've tried both Chrome and Firefox. Also tried clearing history/cookies.
I'm not having any other problems with the PC.

Anyone else having this problem?
Reply 

#2  Sirtel 06-14-2022, 06:41 PM
Nope, I can access the Play store on my Windows 10 laptop (Chrome). Just tried.
Reply 

#3  4691mls 06-14-2022, 08:00 PM
I thought the Windows Devices forum was for reading on Windows devices, not what I'm trying to do, hence posting it in the general forum where more people might see it.

Thanks Sirtel for letting me know it works for you.

I guess I'll try to contact Google.
Reply 

#4  4691mls 06-14-2022, 08:53 PM
I contacted Google via chat help. Eventually discovered that if I signed into Google on Firefox, then cleared history - but in the Clear History dialog had to UNCHECK the "clear active logins" so that wouldn't clear - then I was able to access the Play store.

Still haven't gotten it to work on Chrome.

But at least I was finally able to download my recently purchased book and transfer to my ereaders.
Reply 

#5  4691mls 06-14-2022, 09:05 PM
On playing around with this some more, it looks like signing in on https://play.google.com/store/books (the bookmark I had saved and had used successfully in the past) results in the 500 error.

But on the above page, if I click where it says "your library" it takes me to

https://play.google.com/books and I am able to log in.

I've replaced the bookmark on both browsers.
Reply 

Today's Posts | Search this Thread | Login | Register