Mobileread
Kindle version TOC works on all but iPhone version
#1  gracenote3 08-21-2019, 07:11 PM
I created an EPUB file on Calibre and uploaded it to Amazon KDP. (I didn't use MOBI because it caused errors in my Kindle previewer that I didn't know how to fix.)

My TOC has 3 levels: Chapter, Main heading, and next Subheading. I was abled to edit the TOC in Calibre and nest the headings properly so that it works and looks right. In Kindle previewer, which converted my epub file to something it could read, the TOC worked fine in all versions (Tablet, phone, etc.).

I uploaded the epub file to Amazon and then opened the resulting Kindle book in Kindle for Mac and on my iphone Kindle app. The TOC works on Kindle for Mac, but not on my iphone--the lowest level of the contents (Subheading) doesn't appear in the TOC navigation. Attaching screenshots showing where subheadings appear (Mac) or are missing (iphone).

I called Amazon and they can't help because i created the epub from a third party software (Calibre). Of course they recommended Kindle Create but I'd already giving up because of its limitations and the complexity of this book. I have tried to read through some of the Calibre helps but I cannot find what more I can try to fix this, thus my post.

Grateful for any helps, I'm happy to attach the epub file but won't bother unless requested.
Reply 

#2  kovidgoyal 08-22-2019, 12:46 AM
This is most likely a limitation of the iOS Kindle app, not supporting multi-level tocs beyond level 2. Somebody that uses the Kindle iOS app can confirm that for you.

And the amazon person you spoke to was just blowing you off. They complain if you use calibre to generate their proprietary formats, not if you use it to create an EPUB.
Reply 

Today's Posts | Search this Thread | Login | Register