Mobileread
Problem with KOReader 2019.06 "Sea Buckthorn"
#1  fbrzvnrnd 06-18-2019, 01:57 AM
Hi,
I updated the Koreader to last version, 2019.06 "Sea Buckthorn" on my Onyx M96.

After the installing I have a problem: the highlighting of the text is now very slow. I select the first word, move the stylus over the last word I want highlight and - slowly - the selection start. It could take some seconds when before it toke more or less one second.

I try to reinstall a previous version I downladed in April, and with April version the text highlighting is fast as before. So I think the problem must be related to last version.

Anyone has the same problem?

Fabrizio
Reply 

#2  Frenzie 06-18-2019, 08:28 AM
Would you mind also testing May to make it slightly easier to find a possible culprit?

You could try enabling wakelock, under Settings → Device otoh. Some E Ink Android devices basically go to sleep without that, which might explain what you're seeing.
Reply 

#3  fbrzvnrnd 06-18-2019, 04:36 PM
It seems to be a different problem than I wrote before. I reinstalled the latest version and initially the selection speed was normal. But while reading and underlining, Koreader started to slow down, even in other operations, such as access to menus. I search "enabling wakelock", but I did not found it. In Settings --> Device I only found a option for battery alarm. Thank you for the answer!
Reply 

#4  Frenzie 06-19-2019, 01:51 AM
My bad, it's in settings → screen.
Reply 

#5  fbrzvnrnd 06-19-2019, 02:57 PM
"Keep Screen On" is active, but I'll keep investigate. Today I read and highlight without problems... and after the Onyx tell me I was running out of memory (but I have 700mb free).
I'll take a look to memory usage when Koread starts slowing down again.
Thank you for the support.
Reply 

#6  pazos 06-19-2019, 03:38 PM
There is an issue opened for Onyx devices: https://github.com/koreader/koreader/issues/5073. It is related to flickering (video linked in OP) and frontlight not working.

Your issue seems unrelated (and hopefully fixed with the "keep screen on" setting). Anyways, feel free to keep us updated (here or in github)
Reply 

#7  fbrzvnrnd 06-19-2019, 05:14 PM
Quote pazos
There is an issue opened for Onyx devices: https://github.com/koreader/koreader/issues/5073. It is related to flickering (video linked in OP) and frontlight not working.

Your issue seems unrelated (and hopefully fixed with the "keep screen on" setting). Anyways, feel free to keep us updated (here or in github)
I never had the flickering problem... but I have another model of Onyx.
The "keep screen on" was active when I had the slowness...

I fear must be some memory problem, but I'll check it when Koreader will be slow again, thank you.
Reply 

#8  fbrzvnrnd 06-20-2019, 07:57 AM
It is happened today: koreader became less and less responsive. Clicking on top menu icons took 3/4 seconds to have an answer. I make some screenshot to "memory status" if this could be useful for betatesting.
I also see that launching koreader from "home" page, do not apply the fullscreen, and Koreader is faster. Launching koreader from "application" page, apply the fullscreen but the application is slower. I don't know if this is related.
Reply 

#9  Frenzie 06-20-2019, 01:48 PM
What did it say in memory status? It's fairly rare for it to go over 100 MB, maybe 200. If that were indeed somehow related you could adjust the cache size.
Reply 

#10  fbrzvnrnd 06-28-2019, 05:58 AM
Hi, I made some experiment going from June version to April one and back: the April one is faster. Not only in highlight, but accessing top menus or looking the TOC. The June version sometimes takes 20/30 seconds to navigate TOC, where the April versione takes 1 second. Accessing top menus in April version takes less than one second, where June's version uses 3/4 seconds for the same operation. I took a look to memory and CPU usage, but I did not find anything useful. I don't know how to help the debugging.
Reply 

  Next »  Last »  (1/5)
Today's Posts | Search this Thread | Login | Register