Mobileread
[Gen3] Cybook Gen3 not working (developer issue)
#1  jack-water 11-12-2012, 08:06 AM
Hi everybody,

I hope you can help me guys!

Here my issue:

I bought a Cybook Gen3 512 MB in 2009 (serial: CYBGEN310B). Some time ago I experienced the issue that only now has taken my cybook to death:

the screen is blank, if I try to turn it on the led just flashes green. If I try to charge it, or to link to a windows 7 computer, it doesn't do anything but flashing (the led) red and orange. If I connect many hours to charge then the led flashes green, and the screen still blank.


The first time I experienced this issue was not much time ago I bought it. And it keep appearing sometimes, always getting worse. But after some hard reset (from the button on the back of the device), or a long charge and a reset it came back to work.



I tried to change battery: at its first charge the led was just red. After a while it started flashing red and orange, and the matter still the same..


I am very available to do also complicated things, guys.

So, what can I do?
Reply 

#2  jack-water 11-17-2012, 09:37 AM
ok, it can be closed, I'm afraid it's helpless
Reply 

Today's Posts | Search this Thread | Login | Register