Mobileread
Trouble at Installing Koreader to Kobo Libra
#1  akifcaglar 10-19-2019, 03:40 PM
Hi everybody,


I just got my Libra and i am trying to install koreader on it. However, I couldnt make it

The steps i took are:

I have downloaded koreader-kobo-2019.09.3-84

I have installed KFMon by extracting its files. Then my libra rebooted so i think it was successful .

Then I extracted the koreader i have downloaded to libra's root file but it did not rebooted so i have read the note at the one click install thread which say i have to prevent nikel from checking hidden files. To do that i have appended the code given to do that to Kobo eReader.config file. It looks like in the picture at attachment.

Later, i have deleted koreader from Libra, and unplugged libra. Then i plugged it again, extracted the koreader files again .However, it still did not reboot .

I feel like i am missing a simple thing.

I will be very happy if anyone can help.Thank you



One click installation thread:

https://www.mobileread.com/forums/sh...d.php?t=314220
kobo debug.png 
Reply 

#2  NiLuJe 10-19-2019, 03:49 PM
@akifcaglar:
Quote NiLuJe
NOTE: For proper Kobo Libra H2O support, you'll need to use KOReader version 2019.10 or newer.
(https://github.com/koreader/koreader/wiki/Installation-on-Kobo-devices#touch-mini-glo-aura-glo-hd-aura-hd-aura-h2o-touch-20-aura-one-aura-edition-2-aura-h2o-edition-2-clara-hd-forma-libra-h2o)
Reply 

#3  NiLuJe 10-19-2019, 03:50 PM
Lucky for you, it was released 10 minutes ago. .

(That was a subtle hint to use the install scripts instead of trying to figure out why doing it yourself failed).
Reply 

#4  Frenzie 10-19-2019, 03:53 PM
Well, you could wait until @NiLuJe updates the one-click package with KOReader 2019.10, but I think it should be as simple as:

1. Use the one-click install package as instructed. (At this moment KOReader should fail to start properly on the Libra.)
2. Overwrite the /mnt/onboard/.adds/koreader directory (or wherever it's installed to) with the latest release.

Edit: four minutes too late.
Reply 

#5  akifcaglar 10-19-2019, 04:48 PM
Wow you guys are fast, thank you so much to both <3

It worked with version 10 ^^. Actually, i have seen that version 10 warning but i also have seen people who got managed to make it work with other versions, so i have tried too.

KOReader looks avesome, thank you so much for such a nice app <3
Reply 

#6  Frenzie 10-19-2019, 05:02 PM
Any build from the past few weeks should work out of the box on the Libra, including the one you mentioned. (Which is virtually identical to 2019.10.)
Reply 

#7  NiLuJe 10-19-2019, 05:17 PM
Yeah, I initially misread the exact nightly version you mentioned, so my usual "too old" answer was fired a tad too quickly .
Reply 

#8  akifcaglar 10-19-2019, 05:49 PM
Dont know, maybe i installed it wrong. I installed it as one click installation but that version was actually not from that thread. Maybe this was the reason.

Hehe , anyway your 'too old ' reply still works xd
Reply 

#9  NiLuJe 10-19-2019, 06:32 PM
Yes, the OCP packages *are* packaged differently, so that (mix'n matching install instructions) definitely wouldn't work.

That's, again, a fact that using the install script would have made obvious .
Reply 

Today's Posts | Search this Thread | Login | Register