Mobileread
Calibre Viewer problem
#1  stridell 10-04-2019, 03:20 AM
Hello,
I recently downloaded calibre into my new pc. I also exported all the books that I had in my old pc into my new one. However, the reader in the new pc seems to be different. It shows less features and only parts of the full page. How can I fix this?

This is what it looks like :
https://i.imgur.com/5qGWpws.png
https://i.imgur.com/ElaopdT.png (when I right click for more options)

This is what I have in my old pc:
https://i.imgur.com/kNleRw2.png
Reply 

#2  BetterRed 10-04-2019, 03:26 AM
See ==>> https://calibre-ebook.com/whats-new

BR
Reply 

#3  stridell 10-04-2019, 03:41 AM
Quote BetterRed
See ==>> https://calibre-ebook.com/whats-new

BR
I'm used to the old version, so I'm going to use that one for now. Thank you for the quick response.
Reply 

#4  Tanjamuse 10-04-2019, 04:20 AM
I can't open all my books in the new viewer, I get the following error on at least 3 different books:

Quote
calibre, version 4.0.0
ERROR: Loading book failed: Failed to open the book at D:\Calibre\[WIP Spuffy]\pfeifferpack\Eye of Eleos (762)\Eye of Eleos - pfeifferpack.epub. Click "Show details" for more info.

Traceback (most recent call last):
File "site-packages\calibre\gui2\viewer\ui.py", line 248, in _load_ebook_worker
File "site-packages\calibre\gui2\viewer\convert_book.py", line 162, in prepare_book
WindowsError: [Error 5] Adgang n�gtet
Also, when I open a book it adds a cover I haven't asked for.
Reply 

#5  kovidgoyal 10-04-2019, 04:32 AM
@Tanjamuse: that is an access denied error, check the permissions on your calibre cache folder and/or temporarily disable your antivirus.
Reply 

#6  Tanjamuse 10-04-2019, 04:35 AM
How do I do that on a single library because in other libraries it works fine?

Also, can you add something where it shows the cover created by the Generate Cover plugin instead of an auto-created by Calibre?
Reply 

#7  kovidgoyal 10-04-2019, 04:38 AM
All libraries share the same cache folder, so if it is not working for one particular library then either there is something special about the book sin that library or its an antivirus.

And no, I'm afraid cover generation is not going to be via a plugin. Use the embed metadata tool to embed the plugin covers in the book files, then the viewer will use them instead of generating its own
Reply 

#8  Tanjamuse 10-04-2019, 05:00 AM
I've added the entire Calibre folder (where all my books are) to the exception-list in Avira.

Every folder is write-protected, including the ones that I can view just fine.

I still get the error.
Reply 

#9  kovidgoyal 10-04-2019, 05:03 AM
Its not the library folders its the cache folder, something like C:\Users\whatever\AppData\Local\calibre-cache
Reply 

#10  Tanjamuse 10-04-2019, 05:10 AM
Nope, still doesn't work
Reply 

  Next »  Last »  (1/15)
Today's Posts | Search this Thread | Login | Register