Mobileread
Cutting Edge Linux Sigil PSAs
#1  DiapDealer 07-31-2019, 02:52 PM
I thought I'd stick this Public Service Announcements post here to keep people apprised of issues that may arise from time to time with regard to Sigil on Linux distros that tend to be early adopters of new releases of system libraries.

2019-08 lxml 4.4.0 - this newly released python module and hard dependency for Sigil is currently incompatible with our custom sigil_bs4 python module. We're working on the issue, but it's best to roll back to version 4.3.4 of lxml in the meantime. Using Sigil with lxml 4.4.0 can do damage to your opf/ncx files. Always use EpubCheck to make sure you're not saving anything wonky. EDIT: this one has been fixed in the latest github master branch. That fix will be included in Sigil 0.9.17.

2019-06 Qt5.12.4 - 5.12.4 has a particularly nasty bug that can affect all of the major platforms. Best to stay away from it and opt for 5.12.3 or 5.13.x instead. It's not destructive or anything, but can be quite annoying regarding relaunching dialogs.

Feel free to PM me any new issues you think you might have run into so I can include them here, if need be.

Today's Posts | Search this Thread | Login | Register