Mobileread
Issue with words with Apostrophe's in them
#1  audeojude 11-22-2019, 02:19 PM
I'm not even sure how to describe this. It's not a major issue but is really annoying.

Any book title, description, etc.. basically any text field if it imports a word with an Apostrophe in it such as "Queen's, didn't, Galaxy's" looks like this "Queen' s, didn' t, Galaxy' s"

When you manually correct it and delete the space between the apostrophe and the s it deletes both the apostrophe and the space as if they are seen as one character.

I just updated to calibre 4.4 and am on Ubuntu 19.10.


Just want to say that other than a couple times of the years for similar very small stuff calibre has been one of the smoothest running just works pieces of software that I have used. I have been running the same calibre installation for the last 9 years or so upgraded regularly as upgrades come out. Most of my issues early on were performance related and faster hardware, mostly faster IO, fixed all that.
Reply 

#2  kovidgoyal 11-22-2019, 10:17 PM
I cannot reproduce this on my linux machine. Are those normal apostrophes or "curly" ones. Most likely they are unicode curly apostrophes and whateever font is being used for the interface renders that glyph badly or does not have the glyph present and the fallback font used for it renders it badly.
Reply 

#3  audeojude 11-23-2019, 02:39 PM
Hmm. I really don't understand how the font system interacts with applications. The apostrophe's are not straight like what I am typing now in Don't and apostrophe's. It is more of a curl or dot with curled tail coming down or up depending on whether it is the first or second apostrophe.

I just used some in a libre office document and they look the same. though there isn't a unexpected space after the curled ' .

In calibre if I manually remove the space and ' then when I put the apostrophe back in it is a straight up and down like like I have been typing here in this post.

I'm really uncertain how to approach this. I'm feeling like it is probably some weird system interaction with some setting on my system but the only thing that seems to be having this issue is calibre as I import books or maybe as I update metadata.

Ok I have been playing with it see what is happening and where. In importing metadata using cntrl-d or download metadata function from amazon where it displays correctly on amazon it will import into a book description with the erroneous space after the apostrophe. I also copied and pasted the same text it imported automatically and it added the space in calibre. The same text still in the clipboard buffer pasted into libre office correctly with no space.

If you have any suggestions of things I could try I'm willing to give it a try. I used the gnome tweak utility to change fonts for the system and restarted calibre but am still seeing same behavior even after system fonts in windows and text etc changed. Normally I would have done a bit more troubleshooting myself but as much experience I have in most other areas I don't really know where to attack this one.

any help would be appreciated. Like I said it's not a terrible omg problem but I have hundreds of books with any word with an apostrophe in metadata displaying incorrectly and the only option at this point is manually correcting them.

ok, I just had a horrible thought and went into the body of a book i imported yesterday from amazon and the issue shows up in all the text of the body of the book if viewed in the ebook viewer that is part of calibre. I converted the azw3 to epub and mobi and still shows up in the calibre ebook viewer. Then I downloaded the bookworm ebook viewer and the epub and mobi formats that I just made of that book show correctly in it.

I'm baffled but now after this I am trending back toward a calibre thing but honestly as I stated before it's beyond my troubleshooting abilities. I hope that I was able to clearly describe the troubleshooting steps I have taken clearly for you. If it is unclear don't feel bad saying "hey dude be more clear!" and I will try again.
Reply 

#4  deback 11-23-2019, 08:30 PM
Hit ctrl-F to bring up the find and replace box in the Calibre Editor.

Do a find for apostrophe (as it's displayed in your text) and space and s and space (and a separate find for apostrophe and space and t and space). Then replace with apostrophe and s and space. Do the same replace with apostrophe and t and space. Then hit the smarten punctuation icon in the top menu...to change the straight apostrophes to curly apostrophes. This should fix all of them. You might also have some apostrophe and space and nt and space occurrences to find and replace to apostrophe and nt and space.
Reply 

#5  kovidgoyal 11-23-2019, 10:36 PM
There is no space, it simply how that glyph is being rendered by the font Qt chooses on your system. The simplest fix is to change the font to something that supports it better.
Reply 

#6  audeojude 11-24-2019, 09:24 AM
Quote kovidgoyal
There is no space, it simply how that glyph is being rendered by the font Qt chooses on your system. The simplest fix is to change the font to something that supports it better.
I think I understand.. My system is using gnome fonts which render differently than calibre which is using a qt font? I need to change specifically the qt font selection?
Reply 

#7  audeojude 11-24-2019, 10:16 AM
Ok... I changed the system qt font with no results. I then changed the font in calibre's preferences for the main interface (interface font) from the default to the Ubuntu [10pt] font. This fixed the issue in the display of metadata in titles and book description etc. The issue is still persistent in the book reader for the same book. Not sure what/where I need to select the display font for the book.

I looked in preferences import export then common options where there is a font setting.. changing it didn't fix display in reader.. didn't think it would but it's the only other place I see reference to font selection that I have found so far.

just as a note the default font that was being used in calibre that was causing issue in metadata display in interface was a Noto Sans font.
Reply 

#8  kovidgoyal 11-24-2019, 10:26 AM
The font used by the viewer in controlled in the viewer preferences, which you access by right clicking anywhere in the viewer.
Reply 

#9  audeojude 11-25-2019, 08:11 AM
Quote kovidgoyal
The font used by the viewer in controlled in the viewer preferences, which you access by right clicking anywhere in the viewer.
And it's fixed. that was exactly it. Thank you for your patience and answers the last couple days. Not sure what or why it changed but after changing the font in (Preferences|Look & Feel|Main interface )for calibre behavior and in the reader Right Click|Preferences|Fonts, metadata and book text displays correctly.
Reply 

#10  audeojude 11-25-2019, 08:16 AM
Kicked a few dollars in from paypal. I try to every couple years and it was about time again anyways. :
scott
Reply 

Today's Posts | Search this Thread | Login | Register