Mobileread
Fire HD 8 not recognised
#1  dedfrog 11-18-2019, 07:57 AM
Hi. Thank you for a great program. I'm gutted that it has stopped working on my tablet.

When I attach my Fire HD 8 the Job gets stuck on 'Get list of books on device' for a few minutes, and then says 'Error communicating with device'.

- I have uninstalled and reinstalled Calibre a few times
- I have tried various USB cables and ports
- I have restarted the laptop and tablet numerous times
- I have deleted the driveinfo.calibre and metadata.calibre files numerous times and restarted both etc

I have also

- Checked Preferences->Plugins->Device Interface plugin
- Tried Preferences->Miscellaneous and click debug device detection - it seemed to freeze

The problem actually started when I updated to 4.3 yesterday. But I have tried reinstalling the older version and it no longer works either.

I have also tried connecting wirelessly but that option does not work for me either.

By the way: My tablet seemed to get an update this week. Perhaps that is the reason some ppl are having issues. (See this link https://www.reddit.com/r/kindlefire/comments/dx0mk8/apps_rearranged_themselves/)

Error message:

calibre, version 4.3.0
ERROR: Error: Error communicating with device

Cannot write to file: hr=2147500037 facility=0 error_code=16389 description: Unspecified error

Traceback (most recent call last):
File "site-packages\calibre\gui2\device.py", line 90, in run
File "site-packages\calibre\gui2\device.py", line 513, in _books
File "site-packages\calibre\devices\mtp\driver.py", line 217, in books
File "site-packages\calibre\devices\mtp\driver.py", line 189, in get_driveinfo
File "site-packages\calibre\devices\mtp\driver.py", line 179, in _update_drive_info
File "site-packages\calibre\devices\mtp\driver.py", line 150, in put_calibre_file
File "site-packages\calibre\devices\mtp\windows\driver.py", line 36, in check_thread
File "site-packages\calibre\devices\mtp\windows\driver.py", line 440, in put_file
WPDError: Cannot write to file: hr=2147500037 facility=0 error_code=16389 description: Unspecified error
Reply 

#2  kovidgoyal 11-18-2019, 08:39 AM
That is an error communicating with the device. Usually, this kind of error can be fixed by
following the steps below in sequence. First:

1) Try rebooting both the device and your computer
2) If that does not work, find the files driveinfo.calibre and metadata.calibre on the device
and delete them (you can use Windows Explorer or a file manager on the device itself to do this)
3) Reset the device

If none of those work, you can use one of the wireless communication methods described here:
https://manual.calibre-ebook.com/faq.html#how-do-i-use-calibre-with-my-android-phone-tablet-or-kindle-fire-hd
Reply 

#3  dedfrog 11-18-2019, 09:08 AM
Thanks. I have tried all of those options. (As I said in my post.)
Reply 

#4  kovidgoyal 11-18-2019, 11:11 AM
One of those options is resetting the device. Which you dont seem to have tried. And if you want help with th ewireless connection we will need more information than :it did not work"
Reply 

#5  dedfrog 11-19-2019, 04:41 AM
You mean a factory reset of the tablet? I'm not really keen to try that but I may in the future if nothing else works. (I have done some stuff like installing Google Play and sideloading Android apps on it that is going to be a mission to redo all that after factory reset.)

The Fire 8 HD is a bit of a weird tablet. It's Android but it's also Amazon.

For the wireless connection I attempted the IP address method by typing http://myIPnumber:8080 into Chrome on the tablet, but the page timed out.

I tried with the IP suggested in Calibre, as well as the IP of the PC (which is different). Neither seemed to work on the tablet. It does work on the PC.

I didn't want to pay for Calibre Companion but if nothing else works perhaps I'll do that.

Thanks for your help anyway.
Reply 

#6  kovidgoyal 11-19-2019, 05:20 AM
Pass calibre through your firewall on the PC to access it from the device.
Reply 

#7  dedfrog 11-19-2019, 06:53 AM
I'll try that, thank you.

But first prize would still be using Calibre on the PC. Fire 8s are quite slow, don't like doing difficult tasks :P

No worries. I'll survive.
Reply 

#8  Danpoet 12-10-2019, 06:23 PM
I also have a Fire 8 HD. I installed Calibre on my Windows 1o PC, but there is no "Send to Device" option to connect to my tablet. I uninstalled, and re-installed Calibre with the same result. I have Kindle compatible ebooks in the program, but can't connect to the Fire 8.
Reply 

#9  Danpoet 12-10-2019, 06:32 PM
Debug file for FIre 8 HD
Spoiler Warning below








calibre 4.5 embedded-python: True is64bit: False
Windows-10-10.0.18362-SP0 Windows ('32bit', 'WindowsPE')
32bit process running on 64bit windows
('Windows', '10', '10.0.18362')
Python 2.7.16+
Windows: ('10', '10.0.18362', 'SP0', u'Multiprocessor Free')
Interface language: None
USB devices on system:
(USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a36&rev0000 devinst=9),
USBDevice(vendor_id=0x3f0 product_id=0x8d11 bcd=0x100 devid=usb\vid_03f0&pid_8d11&rev_0100&mi_03 devinst=10),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a38&rev0000 devinst=11),
USBDevice(vendor_id=0xd62 product_id=0x2106 bcd=0x450 devid=usb\vid_0d62&pid_2106&rev_0450 devinst=12),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a37&rev0000 devinst=13),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub20&vid8086&pid3a3a&rev0000 devinst=14),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\vid_1949&pid_0331&rev_???? devinst=8),
USBDevice(vendor_id=0x3f0 product_id=0xc402 bcd=0x100 devid=usb\vid_03f0&pid_c402&rev_0100 devinst=15),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub30&vid1106&pid3483&rev0001 devinst=16),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub20&vid8086&pid3a3c&rev0000 devinst=17),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a39&rev0000 devinst=18),
USBDevice(vendor_id=0x46d product_id=0xc063 bcd=0x5700 devid=usb\vid_046d&pid_c063&rev_5700 devinst=19),
USBDevice(vendor_id=0x3f0 product_id=0xc402 bcd=0x100 devid=usb\vid_03f0&pid_c402&rev_0100&mi_00 devinst=20),
USBDevice(vendor_id=0x2109 product_id=0x812 bcd=0x8574 devid=usb\vid_2109&pid_0812&rev_8574 devinst=21),
USBDevice(vendor_id=0x3f0 product_id=0x8d11 bcd=0x100 devid=usb\vid_03f0&pid_8d11&rev_0100&mi_00 devinst=22),
USBDevice(vendor_id=0x1058 product_id=0x1230 bcd=0x1050 devid=usb\vid_1058&pid_1230&rev_1050 devinst=23),
USBDevice(vendor_id=0xd62 product_id=0x2106 bcd=0x450 devid=usb\vid_0d62&pid_2106&rev_0450&mi_01 devinst=24),
USBDevice(vendor_id=0xd62 product_id=0x2106 bcd=0x450 devid=usb\vid_0d62&pid_2106&rev_0450&mi_00 devinst=25),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a35&rev0000 devinst=26),
USBDevice(vendor_id=0x3f0 product_id=0xc402 bcd=0x100 devid=usb\vid_03f0&pid_c402&rev_0100&mi_01 devinst=27),
USBDevice(vendor_id=0x3f0 product_id=0x8d11 bcd=0x100 devid=usb\vid_03f0&pid_8d11&rev_0100 devinst=28),
USBDevice(vendor_id=0x3f0 product_id=0x8d11 bcd=0x100 devid=usb\vid_03f0&pid_8d11&rev_0100&mi_01 devinst=29),
USBDevice(vendor_id=None product_id=None bcd=None devid=usb\root_hub&vid8086&pid3a34&rev0000 devinst=30),
USBDevice(vendor_id=0x3f0 product_id=0xc402 bcd=0x100 devid=usb\vid_03f0&pid_c402&rev_0100&mi_02 devinst=31),
USBDevice(vendor_id=0x1058 product_id=0x1021 bcd=0x2002 devid=usb\vid_1058&pid_1021&rev_2002 devinst=32),
USBDevice(vendor_id=0x3f0 product_id=0x8d11 bcd=0x100 devid=usb\vid_03f0&pid_8d11&rev_0100&mi_02 devinst=33),
USBDevice(vendor_id=0x2109 product_id=0x2812 bcd=0x8570 devid=usb\vid_2109&pid_2812&rev_8570 devinst=34),
USBDevice(vendor_id=0x2109 product_id=0x3431 bcd=0x420 devid=usb\vid_2109&pid_3431&rev_0420 devinst=35))

No disabled plugins
Looking for devices of type: MTP_DEVICE
List of WPD PNP ids:
[u'\\\\?\\swd#wpdbusenum#_??_usbstor#disk&ven_hp&pr od_photosmart_d110&rev_1.00#7&215459df&0&cn08sf10v d05n9&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}#{6ac27878-a6fa-4155-ba85-f98f491d4f33}',
u'\\\\?\\swd#wpdbusenum#_??_usbstor#disk&ven_hp&pr od_photosmart_d5100&rev_1.00#7&e64f4e1&0&my68m1307 904jr&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}#{6ac27878-a6fa-4155-ba85-f98f491d4f33}',
u'\\\\?\\swd#wpdbusenum#{d1661559-4c5e-11e6-aa2a-0024e80f4a50}#0000000bbc300000#{6ac27878-a6fa-4155-ba85-f98f491d4f33}',
u'\\\\?\\swd#wpdbusenum#{7ddfd814-cd97-11e3-a297-0024e80f4a50}#0000000000100000#{6ac27878-a6fa-4155-ba85-f98f491d4f33}',
u'\\\\?\\swd#wpdbusenum#{d1661559-4c5e-11e6-aa2a-0024e80f4a50}#0000000003f00000#{6ac27878-a6fa-4155-ba85-f98f491d4f33}',
u'\\\\?\\usb#vid_1949&pid_0331#g0w0t9059315fbhs#{6 ac27878-a6fa-4155-ba85-f98f491d4f33}']
MTP device: \\?\usb#vid_1949&pid_0331#g0w0t9059315fbhs#{6ac278 78-a6fa-4155-ba85-f98f491d4f33}
{'device_version': u'1.0',
'friendly_name': u'',
'has_bulk_properties': True,
'has_storage': True,
'manufacturer_name': u'Amazon',
'model_name': u'Fire',
'protocol': u'MTP: 1.00',
'serial_number': u'<removed per user request>',
'storage': [],
'type': 'media player'}
Not a suitable MTP device, ignoring

No suitable MTP devices found

Looking for devices of type: SMART_DEVICE_APP
All IP addresses {u'{0333A3F1-453F-42D1-93AE-5FA77815693F}': [{'broadcast': u'192.168.0.255', 'netmask': u'255.255.255.0', 'addr': u'192.168.0.175'}], u'{7A35C63C-1C11-11E8-B0A6-806E6F6E6963}': [{'broadcast': u'127.255.255.255', 'netmask': u'255.0.0.0', 'addr': u'127.0.0.1'}]}
No device is connected

Looking for devices...

Devices possibly connected: None
Reply 

#10  Danpoet 12-10-2019, 06:45 PM
I ws able to go into the Kindle and allow it to use USB. The Calibre app then showed send to device, and I was able to transfer my files successfully. Kovidgpyal, please delete the debug info if it is listed on the site, as it has my device id listed. Thank you.
Reply 

  Next »  Last »  (1/2)
Today's Posts | Search this Thread | Login | Register